2007 SS/SC idles terrible with A/C on. - Chevy Cobalt SS Forum : Chevrolet Cobalt SS Forums
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 08-13-2009, 10:39 AM Thread Starter
 
Join Date: Aug 2009
Posts: 5
2007 SS/SC idles terrible with A/C on.

Hello,

I have a 2007 Cobalt ss/sc and i love it. Alot. With the exeption that when i turn the A/C on the car idles and bogs down terribly. It nearly dies when i come to a stop. In order to get through 1st gear i have to ride the clutch to keep the rpm's up and prevent stalling.

Any advice would be greatly appreciated because i took it back to the dealer and they say they cant duplicate a problem that isn't "normal working order"

Thanks in advance,
Dave

Last edited by droyd; 08-13-2009 at 11:06 AM.
droyd is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 08-13-2009, 01:12 PM
Contributing User
 
U8_mY_g00ch's Avatar
 
Join Date: Feb 2009
Location: Phoenix, Az
Posts: 414
I have the exact same problem. I haven't brought it up to the dealer yet, but plan to. I have no idea whats going on, I just deal with it, lol

2007 SS/SC
O T T P TVS Stage 3 w/ 2.9" & 80# inj., ZZP 3" CAI, ZZP Stainless Mid-Length Header w/ 3" Catted DP, ZZP Stainless 3" Magnaflow Cat-Back, O T T P Heat Exchanger, Opt B, TTR Upper Engine Mount
U8_mY_g00ch is offline  
post #3 of 12 (permalink) Old 08-13-2009, 01:30 PM Thread Starter
 
Join Date: Aug 2009
Posts: 5
lol yea, that's what i have been doing up until i found a trans leak so it was already at the dealer. Figured i would have them check it out and they just told me "deal with it, its how the car runs"

Kind of sucks.

I also read a few places to clean out the thr***le body for idle issues...may give it a try, it sounds easy enough.
droyd is offline  
 
post #4 of 12 (permalink) Old 08-13-2009, 01:42 PM
Moderator
 
RedSStreak's Avatar
 
Join Date: Feb 2009
Posts: 1,087
Garage
I have the EXACT same problems in the first couple months of owning my 07 SS/SC as you.

My transmission was leaking so I tightened the bolts and my idle is crazy when I have the AC on as well. Good to see that I am not the only one.
RedSStreak is offline  
post #5 of 12 (permalink) Old 08-13-2009, 01:44 PM
Moderator
 
RedSStreak's Avatar
 
Join Date: Feb 2009
Posts: 1,087
Garage
Oh and I have almost 26K miles on my SS/SC and it still does this Idle BS when the AC is on.
RedSStreak is offline  
post #6 of 12 (permalink) Old 08-13-2009, 01:54 PM
Contributing User
 
U8_mY_g00ch's Avatar
 
Join Date: Feb 2009
Location: Phoenix, Az
Posts: 414
yah, me too, im at almost 30. It never died on me so I just let it be and press on.

2007 SS/SC
O T T P TVS Stage 3 w/ 2.9" & 80# inj., ZZP 3" CAI, ZZP Stainless Mid-Length Header w/ 3" Catted DP, ZZP Stainless 3" Magnaflow Cat-Back, O T T P Heat Exchanger, Opt B, TTR Upper Engine Mount
U8_mY_g00ch is offline  
post #7 of 12 (permalink) Old 08-13-2009, 05:16 PM
Moderator
 
RedSStreak's Avatar
 
Join Date: Feb 2009
Posts: 1,087
Garage
Never died either but did set off some misfire codes and CEL. Made me really pissed off because I hate seeing that dreaded light go off....
RedSStreak is offline  
post #8 of 12 (permalink) Old 08-13-2009, 06:17 PM
Contributing User
 
One-Bullet-Banta's Avatar
 
Join Date: Nov 2008
Location: Austin, TX
Posts: 451
had a cavalier once that would do that, and my intake was hindering the thr***le cable from functioning fulley, i didnt have a supercharger though

09 White LSD 4 Door SS
GMPP Stage Kit
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Hahn intake, charge pipes, and cat back
ttr motor mount, CIA downpipe
One-Bullet-Banta is offline  
post #9 of 12 (permalink) Old 08-14-2009, 11:45 AM
Moderator
 
RedSStreak's Avatar
 
Join Date: Feb 2009
Posts: 1,087
Garage
Keep taking it to the dealer and give them a fit about it so that they can do some pretty beneficial modifications to it if its bothering you too much.

I hear that they may even get you a CAI w/short ram if it bothers you that much?? Then it should really be no problem because there is more airflow through your piping.
RedSStreak is offline  
post #10 of 12 (permalink) Old 08-28-2009, 07:37 AM
 
Join Date: Aug 2009
Posts: 2
a/c idle

this may be the problem, have you unhooked the battery? my 00 eclipse gt would do this because the car had to re-learn the idle, try disconnecting the battery for 10 min then start it up and let it idle for another 10 mins, dont touch it. this might work...J
315jsturbo is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Cobalt SS Forum : Chevrolet Cobalt SS Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2007 G5 Upgrades thursdaylsr Performance Modifications 8 01-15-2008 02:05 PM
New owner....2007 SS/SC cogitoergozoom General Discussion 7 10-27-2006 01:51 AM
2007 SS/SC Wheels Whitsel21 General Discussion 14 08-03-2006 04:30 PM
2007 Ss/sc detroit_tuner General Discussion 9 07-31-2006 09:37 AM
2007 Cobalt forced_induction General Discussion 8 06-14-2006 12:29 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome