05 SS battery changed now host of problems.... - Chevy Cobalt SS Forum : Chevrolet Cobalt SS Forums
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 07-20-2016, 03:28 PM Thread Starter
Junior Member
 
Join Date: Jul 2016
Posts: 8
Unhappy 05 SS battery changed now host of problems....

Hi guys.

Sorry for long detailed post.

I used to be here way back in 05 under name 44Dwarf but i'm locked out of that now and can't seem to get password to reset ect. Any....
My 05 SS has done more sitting in the last 4 years then driving as my job had me in a service van.
The OEM battery died over the winter. I replaced it with a charged up new battery from Advanced (I wanted an interstate but no one had stock).
Car was fine for a few days then i got the dreaded no crank problem. Battery testing showed low resistance and 150 more then spec CCA on the new battery.
After some research here i swapped around relays with no change. After some more research i found a post about the computer connections in front of the fuse box so i Disconnected the battery removed the air cleaner tube and used CRC contact cleaner and compressed air to clean the outsides of the connectors and one by open opened them and pulled them off. the top two were clean and dry....the bottom one had oil inside! i later found out it was from a split hose going to the air cleaner tube. Anyway cleaned the computer side and the connector side even popped the top off the connector and cleaned the wire side.
Reassembled and connected the battery car with turn over and start now HOWEVER there is now a 2-3 second delay in when the key is turned to when the engine cranks. Okay i can live with that i guess...My inspection is long over due and I've been trying to get the 5 monitors to come up OKAY so it can get a new sticker.
Now i found i have only 2psi of boost (1st time ever its not built boost) so more research i find intercooler pump is bad so i got a new one put it in and bleed the system via the bolt on the rad and burping it on the filler.
So more diving to get the EVAP monitor to come in okay and up pops the security light....
The only code reader i have will not look at live signals ect it a reader / clearer but i have no check engine light just limited boost and now the security car lock light.
Short of taking to the dealer anyone know how to clear the security light?
Thanks.

05 Cobalt SS 100% stock.

"Smok'in the competition NOT Tobacco"
"Transplant organs, Don't bury them!"
Anthony Leary is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 07-20-2016, 09:17 PM
Contributing User
 
Join Date: May 2014
Posts: 44
Hows the charging unit by the way?
cobalt-red is offline  
post #3 of 7 (permalink) Old 07-21-2016, 10:46 AM Thread Starter
Junior Member
 
Join Date: Jul 2016
Posts: 8
Alt tested fine after new battery (with load tester) was in and everything was working fine for a couple of days. After my post last night i tried to Re-learn the PASSlock and now its locked up solid and with not turn over at all...
WTH... I still love the car but this is nuts its bad enough i have to pull the disks every time i need to use the car and skim them on the lathe. Real miss my reliable car hate having to use my v10 pick up to go around town.

05 Cobalt SS 100% stock.

"Smok'in the competition NOT Tobacco"
"Transplant organs, Don't bury them!"
Anthony Leary is offline  
 
post #4 of 7 (permalink) Old 07-23-2016, 02:16 PM Thread Starter
Junior Member
 
Join Date: Jul 2016
Posts: 8
Disconnected battery for 28+ hours. Put battery on charger just to be sure it was 100%. Reconnected the battery the security light is out now but still have no cranking...

Anyone got full wire diagram for 05 SS?

05 Cobalt SS 100% stock.

"Smok'in the competition NOT Tobacco"
"Transplant organs, Don't bury them!"
Anthony Leary is offline  
post #5 of 7 (permalink) Old 07-26-2016, 11:35 AM Thread Starter
Junior Member
 
Join Date: Jul 2016
Posts: 8
Well I started digging some more and looks like my starter solenoid is dead when i use a screw drive to short the two big terminals on the starter (battery cable to stater motor post) the motor spins however when i short the battery to the small post i get a current draw but no throw out of the starter gear nor spinning of the motor.
So we wait for new starter to get here and hopefully my reliable car returns. Strange how both the solenoid and the intercooler pumps died at same time or with in a few days.... but at 143,000 and 11 years old its a first for both.
I hope this fixes everything once and for all.

05 Cobalt SS 100% stock.

"Smok'in the competition NOT Tobacco"
"Transplant organs, Don't bury them!"
Anthony Leary is offline  
post #6 of 7 (permalink) Old 07-29-2016, 02:56 PM Thread Starter
Junior Member
 
Join Date: Jul 2016
Posts: 8
Starter changed it runs again, no delay in cranking! Took on a nice ride no boost. After two stops where i shut down the motor and let it sit 20 or so minutes each time still no boost but then 15 miles later full boost! then the dreaded security light came back but i can turn the car off and it clears only to pop up again and boost is intermittent on whether it will be there or not...No passing RV trailers on the twistys with no boost...
So what do i need to do to clear the security light once and for all and is that killing my boost? Intercooler pump is working and bleed of air.

05 Cobalt SS 100% stock.

"Smok'in the competition NOT Tobacco"
"Transplant organs, Don't bury them!"
Anthony Leary is offline  
post #7 of 7 (permalink) Old 08-02-2016, 12:06 PM Thread Starter
Junior Member
 
Join Date: Jul 2016
Posts: 8
Boost seemed to come and go as it wanted as did the security light after 120 miles driving out of state it finaly had all but the evap monitors ready. Got to the inspection station and guy there used his OBD2 unit to force Evap check and it was fine got my sticker and cars running great full boost now for over 200 miles!

05 Cobalt SS 100% stock.

"Smok'in the competition NOT Tobacco"
"Transplant organs, Don't bury them!"
Anthony Leary is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Cobalt SS Forum : Chevrolet Cobalt SS Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Changed pads now soft brakes mxkx250 Wheels, Tires, Brakes, and Suspension 1 04-07-2013 09:10 PM
Mfba To Host Open Track @ Road America Racer X Road Racing/Autocross Discussion 0 03-10-2008 11:49 PM
Project changed, selling many parts victory_red_SS Parts Wanted/Parts for Sale 5 02-08-2007 09:15 PM
dead battery (changed Pulley ) REDLX347 Problems/Dealer Service 1 02-17-2006 02:55 PM
Header image changed... what do you think? ekool General Discussion 21 01-25-2005 07:54 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome