Lifter - Chevy Cobalt SS Forum : Chevrolet Cobalt SS Forums
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 04-07-2007, 02:41 PM Thread Starter
 
Join Date: Apr 2007
Posts: 22
Lifter

I just took in my 07 Cobalt that i bought in Feb 07. The Dealer said that the lifter of bank 4 came loose. I heard a tapping and I knew i had to take it in to have it checked out. The Dealer stated that the cause of the lifter coming loose was because of the oil filter. The oil was changed at Firestone about a week and a half ago. Dealer said that the wrong oil filter was installed on the Cobalt and thus caused the oil not to reach the lifter on time and caused it to come loose. Anyone ever heard of anything like this? Dealer also stated that this was the 2nd Cobalt that it has happened this year.
07blkcobalttxn is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 04-12-2007, 03:41 PM
 
Join Date: Feb 2007
Posts: 122
Nope never heard about this happening i have an '07 SC yea ive been kinda iffy about taking my car to other places to change the oil. Id say you should just take it to the dealership for now on to avoid it ever happening again but im pretty sure you already figuared that much on your own huh haha.
2k7eatonSS is offline  
post #3 of 4 (permalink) Old 04-12-2007, 07:54 PM
 
Join Date: Oct 2006
Posts: 784
I dont let anyone do anythign but my dealership that way if something gets fucked its their fault. I even let them install my aftermarket parts.
suprchged is offline  
 
post #4 of 4 (permalink) Old 04-14-2007, 06:30 PM Thread Starter
 
Join Date: Apr 2007
Posts: 22
The Stealership said that the lifter in bank 4 came loose and was making the noise. This happened according to them because the wrong oil filter was installed at the time the oil change was done. The oil change was done about 2 weeks ago at Firestone here in El Paso, Tx. Turns out that the oil filter did not have a valve in it or something and would not allow oil to reach the lifters in time. Stealership replaced all 4 lifters and changed the oil along with the oil filter. The car is now running correctly. Took them 4 days to do the job.
07blkcobalttxn is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Cobalt SS Forum : Chevrolet Cobalt SS Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome