clutch problem - Chevy Cobalt SS Forum : Chevrolet Cobalt SS Forums
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 08-29-2007, 05:38 PM Thread Starter
 
Join Date: Jun 2006
Posts: 1,322
clutch problem

has anybody had a problem with their clutch pedal going to absolutely nothing for a few seconds and then have a perfect clutch pedal again, like it never happened at all. and sometimes when i punch it at 4k rpm in second and let off at 6k rpm i have to pump the pedal back up like a worn out mastercylinder anybody run across this problem let me know
jonsstockrocket is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 09-03-2007, 04:30 PM
 
Join Date: Aug 2007
Posts: 6
Well, I'm having pretty much the same problem...Launch at around 1300 RPM run up to near redline hit second and what seems like clutch slippage sets in... builds RPM with no movement, I wonder if warranty covers this at 24,000 miles?

so (this thread) x2!!
06blackss/sc is offline  
post #3 of 3 (permalink) Old 09-03-2007, 08:11 PM
 
Join Date: Aug 2006
Posts: 2,649
IDK man, my car has acted up something like that before, good to see you on the forums jon! Maybe its something across the board....
JohnsRallyYellowSS is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Cobalt SS Forum : Chevrolet Cobalt SS Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Clutch Problem??? BaltSS07 General Discussion 3 02-04-2007 09:42 PM
CAI problem help!!!! Video2402 Performance Modifications 5 04-22-2006 03:50 AM
this clutch slipping problem rivalm05 General Discussion 6 03-25-2006 06:30 PM
SS problem phxSS Problems/Dealer Service 10 07-30-2005 05:50 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome