clutch issues - Chevy Cobalt SS Forum : Chevrolet Cobalt SS Forums
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 07-22-2008, 05:06 PM Thread Starter
 
Join Date: Jun 2006
Posts: 1,322
clutch issues

i have a question for anyone who wants to answer. when i race and get the rpm's up the clutch seems to just go away then i pump the pedal a few times. it gets stronger but for the clutch to work properly i have to leave it engaged then it goes back to normal. i replaced the clutch master and i am thinking about changing the clutch. does anyone have any suggestions or have you run into the same problem?
jonsstockrocket is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 08-12-2008, 02:40 PM
 
Join Date: Aug 2008
Posts: 2
yes i have ran i to the same problem but now that i had the dealership to replace my clutch and then synchro went out about 2 months later and now i have nothing at all and i was told they looked at everything in the tranny if u have any suggestions for me i would greatly appreciate and advice thhat is given

superchargednic24
superchargednic24 is offline  
post #3 of 5 (permalink) Old 08-15-2008, 07:18 PM
Super Moderator
 
skoal*boy's Avatar
 
Join Date: Aug 2008
Location: Fort Bragg NC
Posts: 1,639
Garage
it sounds like you need a aftermarket clutch. but you need to contact your dealership and let them know, you have to think that when they make these cars they really dont use top of the line parts. i cant tell you off the top of my head how much the aftermarket clutches are but there not that hard to find. try www.pfyc.com, www.everythingcobalt.com, and andysautosports.com or google them. hope that helps
skoal*boy is offline  
 
post #4 of 5 (permalink) Old 08-21-2008, 03:59 PM Thread Starter
 
Join Date: Jun 2006
Posts: 1,322
Quote:
Originally Posted by superchargednic24 View Post
yes i have ran i to the same problem but now that i had the dealership to replace my clutch and then synchro went out about 2 months later and now i have nothing at all and i was told they looked at everything in the tranny if u have any suggestions for me i would greatly appreciate and advice thhat is given

superchargednic24
was your transmission the MU or the G85
jonsstockrocket is offline  
post #5 of 5 (permalink) Old 08-21-2008, 04:02 PM Thread Starter
 
Join Date: Jun 2006
Posts: 1,322
Quote:
Originally Posted by skoal*boy View Post
it sounds like you need a aftermarket clutch. but you need to contact your dealership and let them know, you have to think that when they make these cars they really dont use top of the line parts. i cant tell you off the top of my head how much the aftermarket clutches are but there not that hard to find. try www.pfyc.com, www.everythingcobalt.com, and andysautosports.com or google them. hope that helps
i have been told several times its probably the clutch but i was also told that the clutch slave could be the problem just so you know the clutch master is what the dealership told me to replace and it did not fix it
jonsstockrocket is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Cobalt SS Forum : Chevrolet Cobalt SS Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mod lists and issues with them dervin3 General Discussion 9 06-19-2010 02:12 AM
Anybody got any vibration issues Domestic Rice General Discussion 2 11-25-2006 08:44 PM
Radio Issues NJGTP General Discussion 5 02-25-2006 11:36 PM
Issues DDogsrt461BLK 2.0 Picture/Media Post 3 02-09-2006 11:08 PM
My radio got issues KillahKermitt Problems/Dealer Service 6 12-02-2005 12:12 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome