Check Engine Light - Chevy Cobalt SS Forum : Chevrolet Cobalt SS Forums
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 07-05-2005, 02:02 PM Thread Starter
 
Join Date: Jul 2005
Posts: 40
Check Engine Light

I just got a brand new, black cobalt ss. I absolutley love everyting about this car. the second day i had it the check engine light was on, so i called the dealership and they said its probably nothingand to birng it in, in a few days. the next day i was cruisin around and went to circuit city. got back in my car and the engine barely started. as it sat there puttering i tried to feed it some gas but it was like the gas pedal no longer served a purpose. i dont know much about cars, but all i know now is that my SS is in the shop and im pretty pissed off. anyone else have any simaliar problems?
labelkills98 is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 07-05-2005, 05:21 PM
 
Join Date: Apr 2005
Posts: 283
Me.... my check engine light came on 2 so I had it in there 2 different times the first time was because some wire or wires was shorting out the fan to cool the engine then the 2 time was they had to replace the hole fuse box in my car and so far that's it man...
BizoCG is offline  
post #3 of 11 (permalink) Old 07-05-2005, 05:57 PM
 
Join Date: Jun 2005
Posts: 695
OMG I HAVE THAT SAME PROBLEM! mine died about amonth ago or so. brought it to the dealer but they coulndt find anythign wrong with it. they just recharged my battery over night and it was fine. i guess there is somethign draining the battery. lately.. started like a few days ago.. it starst puttering like yours and it hestiates to start. so it looks like i am going to ahev to bring mine back to teh dealership too.
foXll17 is offline  
 
post #4 of 11 (permalink) Old 07-05-2005, 09:44 PM
 
Join Date: Jul 2005
Posts: 22
Had the same problem on day 2 after buying mine. The dealer put 1/4 tank of 87 octane gas of one brand for the test drive. The next day they filled the tank, again with 87. Don't ask me why but when my tank hit 1/4 full my engine light came on and I lost a lot of power. I checked the manual and tried the only thing that I could do myself was re-install the gas cap to clear the engine sensor. I had some bad smell from the exhaust for a few minutes then eveything went back to normal. I burnt the rest of the 87 gas and filled with 91 Petro Can Supreme and have been running smoothe ever since.
RedSS30 is offline  
post #5 of 11 (permalink) Old 07-07-2005, 07:10 AM Thread Starter
 
Join Date: Jul 2005
Posts: 40
thanks guys for the feed back. i just got it back and everything seems to be running fine. although i need to take it back because the lights on the mirror dont turn on but i couldnt really care less right now because all i want to do now is drive. who needs interrior lights anyway right? haha
labelkills98 is offline  
post #6 of 11 (permalink) Old 07-07-2005, 08:03 AM
 
Join Date: Jun 2005
Posts: 58
Quote:
Originally Posted by labelkills98
thanks guys for the feed back. i just got it back and everything seems to be running fine. although i need to take it back because the lights on the mirror dont turn on but i couldnt really care less right now because all i want to do now is drive. who needs interrior lights anyway right? haha
Depending on how that part of the electircal system is designed, it could be bigger than you think. Commonly multiple grounds are combined into one grounding point. If it is loose / broken / disconnected it could cause many problems. I'll edit this post when I find which grounds are common with the interior lights. The thing with electrical problems is that there could be a different harness used for cars that were next to each other on the line. Harness revesions can and do occur in just a few days.

EDIT: Ignore this post, all it seems to do is try to make a seemingly small problem into a larger one. It could be a larger electrical problem, but it is probably not. It could be just a short that is draining your battery and throwing off your computer, or it could be something totally different. I really have no idea, would just be talking out of my ass if I tried to actually diagnose your problem.

Last edited by ericsean; 07-07-2005 at 08:21 AM.
ericsean is offline  
post #7 of 11 (permalink) Old 07-07-2005, 08:32 AM
 
Join Date: Jun 2005
Posts: 695
what was wrong with the check engine light coming on?
foXll17 is offline  
post #8 of 11 (permalink) Old 07-07-2005, 10:16 AM Thread Starter
 
Join Date: Jul 2005
Posts: 40
my gas pump went bad. my engine wasnt getting any gas i guess when i tried to start it. they had to put in a brand new one. its fine now, just be careful and take the light seriously because i thought it was just a loose fuse or something, but it deffintly was something big. like my gas pump.

- thanks ericsean for the input, the dealer told me it was something with the fuse box but they had to order something that wont be in until monday so i;ll know then what it was. i;ll let everyone know
labelkills98 is offline  
post #9 of 11 (permalink) Old 07-07-2005, 11:05 AM
 
Join Date: Jun 2005
Posts: 58
Quote:
Originally Posted by labelkills98
[snip] the dealer told me it was something with the fuse box but they had to order something that wont be in until monday so i;ll know then what it was. i;ll let everyone know
The fuse box eh? This could be interesting. I work for an wiring harness supplier thats why I say so. I deal with wiring harness "stuff" all day long.
ericsean is offline  
post #10 of 11 (permalink) Old 07-07-2005, 03:48 PM
Junior Member
 
Join Date: Mar 2005
Posts: 17
Quote:
Originally Posted by labelkills98
I just got a brand new, black cobalt ss. I absolutley love everyting about this car. the second day i had it the check engine light was on, so i called the dealership and they said its probably nothingand to birng it in, in a few days. the next day i was cruisin around and went to circuit city. got back in my car and the engine barely started. as it sat there puttering i tried to feed it some gas but it was like the gas pedal no longer served a purpose. i dont know much about cars, but all i know now is that my SS is in the shop and im pretty pissed off. anyone else have any simaliar problems?

that sucks
dodgeZ is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Cobalt SS Forum : Chevrolet Cobalt SS Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome