No clutch disengagement - Chevy Cobalt SS Forum : Chevrolet Cobalt SS Forums
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 11-25-2019, 02:07 PM Thread Starter
Junior Member
 
2006SSG85's Avatar
 
Join Date: Nov 2019
Posts: 1
No clutch disengagement

I have a 2006 SS/SC with the G85 4.05 LSD I push the clutch in and have pedal feel but no full disengagement. I can start it in gear and it just goes and can’t get it out of gear with the car on, and won’t go in gear while running but doesn’t grind when I try. When I have it up on jack stands and have it in gear and I rotate the tires there is very little resistance like it’s not connected to the engine and the wheels spin opposite of each other in any gear. I am at a loss with what is going on and can’t find any solution with research.
2006SSG85 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Cobalt SS Forum : Chevrolet Cobalt SS Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome