2007 SS 2.4 Starving for fuel?? - Chevy Cobalt SS Forum : Chevrolet Cobalt SS Forums
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 07-24-2010, 09:03 AM Thread Starter
Junior Member
 
Join Date: Jul 2010
Posts: 4
2007 SS 2.4 Starving for fuel??

I'm not sure if i'm posting this in the right spot but here goes.
I have a 2007 Cobalts SS1 with the 2.4 and the car is bucking on me. It seems like it's starving for fuel. When i'm driving along and drop down a couple of gears and give er' she just bogs out. I put a new fuel filter on and thought the problem was fixed, took it for a run and it worked perfect. The next day it's doing the same thing again. It doesn't do it all the time, but it does it alot. No engine light coming on, so no codes. Does anyone know what's causing this problem I'm thinking fuel pumps on the way out. Car only has 88000 KM's on it. Any help would be appreciated. Thanks

Last edited by VinnySS1; 07-24-2010 at 09:06 AM.
VinnySS1 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 07-25-2010, 08:50 AM Thread Starter
Junior Member
 
Join Date: Jul 2010
Posts: 4
BUMP Someone must know something, come on people.
VinnySS1 is offline  
post #3 of 5 (permalink) Old 07-25-2010, 01:52 PM
Super Moderator
 
skoal*boy's Avatar
 
Join Date: Aug 2008
Location: Fort Bragg NC
Posts: 1,639
Garage
um yea maybe. or your injectors might be dirty.

I was beat by RKRamos.
skoal*boy is offline  
 
post #4 of 5 (permalink) Old 08-01-2010, 10:12 PM Thread Starter
Junior Member
 
Join Date: Jul 2010
Posts: 4
Wellllllll....not much help on here I see. Thanks for NOTHING people. I took a little look at it myself, took the plugs out ang regapped them, 2 were way out of whack. They were all burning great though. Dealer said plugs were good for 160,000KM's. They still look like new but the gaps were out. Car has been working great since, going on 4 days now.
VinnySS1 is offline  
post #5 of 5 (permalink) Old 08-03-2010, 06:09 PM
The HepKitty
 
LittleMT's Avatar
 
Join Date: May 2005
Posts: 1,329
Quote:
Originally Posted by VinnySS1 View Post
Wellllllll....not much help on here I see. Thanks for NOTHING people. I took a little look at it myself, took the plugs out ang regapped them, 2 were way out of whack. They were all burning great though. Dealer said plugs were good for 160,000KM's. They still look like new but the gaps were out. Car has been working great since, going on 4 days now.
you are one happy fellow, what are you saying, the plugs that needed to be regapped, I take it the gaps were to large and you were experiencing spark plug blow out from the boost?

...

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

the Bop that never Stopped...
Chantilly Lace - The Rolling Rockabilly Jukebox..
LittleMT is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Cobalt SS Forum : Chevrolet Cobalt SS Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2007 ss/sc colors NewKid General Discussion 9 03-14-2007 02:43 AM
New owner....2007 SS/SC cogitoergozoom General Discussion 7 10-27-2006 02:51 AM
2007 SS/SC Wheels Whitsel21 General Discussion 14 08-03-2006 05:30 PM
2007 Ss/sc detroit_tuner General Discussion 9 07-31-2006 10:37 AM
2007 Cobalt forced_induction General Discussion 8 06-14-2006 01:29 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome