Problem With My Cobalt SS (Loud Squeek) - Chevy Cobalt SS Forum : Chevrolet Cobalt SS Forums
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 02-26-2011, 02:21 AM Thread Starter
Contributing User
 
Join Date: Jun 2009
Location: United States, Illinois
Posts: 84
Send a message via AIM to ThinkRusty87 Send a message via MSN to ThinkRusty87 Send a message via Skype™ to ThinkRusty87
Problem With My Cobalt SS (Loud Squeek)

I start the car and there is a loud squeek comming from the passenger side. It also is loud when i rev or on the throttle. Its comming from one of the pulleys? Anyone know what this could be?
ThinkRusty87 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 02-27-2011, 01:42 PM
Super Moderator
 
skoal*boy's Avatar
 
Join Date: Aug 2008
Location: Fort Bragg NC
Posts: 1,639
Garage
the belt....

I was beat by RKRamos.
skoal*boy is offline  
post #3 of 8 (permalink) Old 02-27-2011, 02:37 PM Thread Starter
Contributing User
 
Join Date: Jun 2009
Location: United States, Illinois
Posts: 84
Send a message via AIM to ThinkRusty87 Send a message via MSN to ThinkRusty87 Send a message via Skype™ to ThinkRusty87
I figured it might be that. How much would it cost to repair? can i do it myself? or should i take it to the dealership?
ThinkRusty87 is offline  
 
post #4 of 8 (permalink) Old 02-27-2011, 07:31 PM
Super Moderator
 
skoal*boy's Avatar
 
Join Date: Aug 2008
Location: Fort Bragg NC
Posts: 1,639
Garage
yea i know you can do it your self. I dont know how hard it is on these motors tho..

I was beat by RKRamos.
skoal*boy is offline  
post #5 of 8 (permalink) Old 02-28-2011, 05:24 PM
Moderator
 
RedSStreak's Avatar
 
Join Date: Feb 2009
Posts: 1,087
Garage
The belt is on the right side of the motor and it is quite a squeeze to get into if you are a newbie. But it should be pretty manageable. If changing the belt doesn't solve the problem, it may be the pully. Good luck!

Any questions about the Balt, all answered here:

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
RedSStreak is offline  
post #6 of 8 (permalink) Old 03-10-2011, 03:52 PM Thread Starter
Contributing User
 
Join Date: Jun 2009
Location: United States, Illinois
Posts: 84
Send a message via AIM to ThinkRusty87 Send a message via MSN to ThinkRusty87 Send a message via Skype™ to ThinkRusty87
I replaced the belt and it is still squeeking. I think its either the tensioner pulley, or a bad bearing in one of the pulleys? What does everyone think? What else could it be?
ThinkRusty87 is offline  
post #7 of 8 (permalink) Old 03-13-2011, 09:20 AM
Super Moderator
 
skoal*boy's Avatar
 
Join Date: Aug 2008
Location: Fort Bragg NC
Posts: 1,639
Garage
look at one of the pulleys

I was beat by RKRamos.
skoal*boy is offline  
post #8 of 8 (permalink) Old 03-15-2011, 05:05 PM
Junior Member
 
Join Date: Mar 2011
Location: Springfield Pa
Posts: 5
Take the belt off and run for a few seconds if noise gone. spin and feel
idler and alt .
57 chevy is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Cobalt SS Forum : Chevrolet Cobalt SS Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cobalt Clutch Problem U8_mY_g00ch Problems/Dealer Service 23 04-01-2009 01:35 PM
exhaust leak sounds and tranny is loud when shifting clayd6287 Problems/Dealer Service 0 08-27-2007 11:19 PM
Problem with Cobalt SS csvt Problems/Dealer Service 8 06-28-2005 10:43 AM
intake problem for base cobalt wikkymaster Performance Modifications 2 05-30-2005 04:10 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome