08 cobalt ss missing engine piece? - Chevy Cobalt SS Forum : Chevrolet Cobalt SS Forums
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 12-26-2013, 06:05 PM Thread Starter
Junior Member
 
Join Date: Dec 2013
Posts: 2
08 cobalt ss missing engine piece?

Hi, I just got a 08 cobalt ss that has 12,000 miles. I was looking at pictures and I saw that all the engines had this one piece on top of the exhaust manifold that was silver and circle thing. It also has this cord that goes into the main wiring harness that looks like it was spliced in. I also wonder what that is. So can u guys help me out?
Attached Thumbnails
Click image for larger version

Name:	image.jpg
Views:	85
Size:	265.2 KB
ID:	1890  
08cobaltss is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Cobalt SS Forum : Chevrolet Cobalt SS Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Missing vacuume hose. Multiple problems?? stasiowski Problems/Dealer Service 2 11-28-2011 08:09 PM
Pontiac G5 grille piece JohnsRallyYellowSS Off-Topic Discussion 1 01-10-2007 07:33 AM
Front end missing somthing????? forced_induction General Discussion 18 07-04-2006 03:23 AM
WTB: interior piece RollOver360 Parts Wanted/Parts for Sale 2 04-22-2006 08:54 AM
No PS pump? Am I missing something? 2kwik4u General Discussion 17 07-24-2005 03:05 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome