Wtf? - Chevy Cobalt SS Forum : Chevrolet Cobalt SS Forums
Closed Thread
 
LinkBack Thread Tools Display Modes
post #1 of 51 (permalink) Old 12-26-2006, 01:06 PM Thread Starter
 
Join Date: Oct 2006
Posts: 784
Wtf?

Man the hell with cobalts I have had two ss/sc an 06 that was such a pile of shit i traded it in for an 07 now my whole pcm and ecu has to be replaced, good luck to everyone else but i have had it, . chevrolet can kiss my ass.
suprchged is offline  
Sponsored Links
Advertisement
 
post #2 of 51 (permalink) Old 12-26-2006, 03:37 PM
 
Join Date: May 2006
Posts: 147
LOL the funny thing is...I have heard nothing but problems about the SC/SS ...but I have a 2.4 SS that has not had one issue LOL
SuperSweet06SS is offline  
post #3 of 51 (permalink) Old 12-26-2006, 04:40 PM
 
Join Date: Jul 2006
Posts: 177
I feel ya

I don't regret getting the 2.0 but it does honestly feel like someone hurried to put it together. The people who have the 2.4 are in good shape, but I wouldn't trade my g85 for the sweetest looking 2.4 on the streets. I just like the racing seats, boost gauge, power, bla bla bla.... The rattle is what kills me in my car. It drives me nuts!
jwolf8604 is offline  
 
post #4 of 51 (permalink) Old 12-26-2006, 08:05 PM Thread Starter
 
Join Date: Oct 2006
Posts: 784
Quote:
Originally Posted by jwolf8604 View Post
I don't regret getting the 2.0 but it does honestly feel like someone hurried to put it together. The people who have the 2.4 are in good shape, but I wouldn't trade my g85 for the sweetest looking 2.4 on the streets. I just like the racing seats, boost gauge, power, bla bla bla.... The rattle is what kills me in my car. It drives me nuts!
dude i feel you is yours an 06 because that what happened to me i was thinking while my pcm was out for them just to go ahead and reflash it to stage 1 specs and the injectors.
suprchged is offline  
post #5 of 51 (permalink) Old 12-26-2006, 10:31 PM
 
Join Date: Jun 2006
Posts: 1,322
ive had a few problems in my 05 but since warranty ran out no problems
jonsstockrocket is offline  
post #6 of 51 (permalink) Old 12-27-2006, 12:53 AM
 
Join Date: Aug 2006
Posts: 2,649
Only just cosmetic flaws in mine, no internal failures.
JohnsRallyYellowSS is offline  
post #7 of 51 (permalink) Old 12-27-2006, 08:43 PM
Contributing User
 
Join Date: Dec 2006
Location: wyoming
Posts: 54
I've had mine for a week now, and over the Christmas weekend I put about 750 miles on it, and I bought it with only 40. I didn't have any problems til it snowed, those tires don't get around in snow for shit, finally had to spin my way home and get my AWD Talon, even though the clutch is almost gone in it. But since that snow day with the Cobalt, its got a funky squeal coming from somewhere, wouldn't have expected something like that out of it quite yet...

~~Kerri~~
07 ss/sc (stage 2 w/ 2.9, cai, 2.5" resonated cat-back)
94 Talon TSi AWD (too much)
DSMissed is offline  
post #8 of 51 (permalink) Old 12-27-2006, 09:19 PM
 
Join Date: Aug 2006
Posts: 2,649
Quote:
Originally Posted by DSMissed View Post
I've had mine for a week now, and over the Christmas weekend I put about 750 miles on it, and I bought it with only 40. I didn't have any problems til it snowed, those tires don't get around in snow for shit, finally had to spin my way home and get my AWD Talon, even though the clutch is almost gone in it. But since that snow day with the Cobalt, its got a funky squeal coming from somewhere, wouldn't have expected something like that out of it quite yet...
Do like everyone else does, take it to the dealer. Also, did any snow or moisture get into the engine bay? If so, it may be causing the belt to slip, causing the noise. And yeah, the tires are shit. Ive had no snow in NC, but wet traction sucks ass, you have to drive in 4th to keep from hydroplaning.
JohnsRallyYellowSS is offline  
post #9 of 51 (permalink) Old 12-30-2006, 03:38 PM Thread Starter
 
Join Date: Oct 2006
Posts: 784
Quote:
Originally Posted by JohnsRallyYellowSS View Post
Do like everyone else does, take it to the dealer. Also, did any snow or moisture get into the engine bay? If so, it may be causing the belt to slip, causing the noise. And yeah, the tires are shit. Ive had no snow in NC, but wet traction sucks ass, you have to drive in 4th to keep from hydroplaning.
yeah those perellis can kiss my ass BFG's KDW 225/40 next time
suprchged is offline  
post #10 of 51 (permalink) Old 12-30-2006, 04:10 PM
 
Join Date: Mar 2005
Posts: 134
hell, im running 40k on my ss balt and shes running awesome. 1 cel problem back at 32k~ but it was just a fuel filter issue.
deuses300c is offline  
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Cobalt SS Forum : Chevrolet Cobalt SS Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome