need help.!! - Chevy Cobalt SS Forum : Chevrolet Cobalt SS Forums
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 04-27-2011, 03:01 AM Thread Starter
Junior Member
 
Join Date: Apr 2011
Location: Jaffrey N.H
Posts: 17
Garage
need help.!!

So i got an 06 cobalt ss/sc last november with 50k on it. just the other day it started blowing black smoke, it is also ideling fu**ed up, and it stalled on me at a light the other day. the mil light is on, i pulled the codes and they all have to do with MAF or 02 sensor. i have read on some forums that cobalts run rich( meaning black smoke) i have a stage 2 kit and an F5 cold air intake. what i dont have is an exhaust, is not having an exhaust with the stage 2 kit making my 02 sensor bad? i also cleaned the MAF sensor too. does any one have any ideas to help me? could my TP sensor be bade?
Adamlovering is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 04-27-2011, 03:04 PM
Moderator
 
RedSStreak's Avatar
 
Join Date: Feb 2009
Posts: 1,087
Garage
Not having a stage 2 exhaust has nothing to do with it running like that. You definitely need to change the O2 sensors and make sure all the piping is strapped correctly on the intake. Then clear the codes and they should shut right off. Common problem:

CHECK THE SUPERCHARGER PIPING AND THE CODES DISAPPEAR.

If you want to go with a better exhaust system, I highly recommend Magnaflow because it will make your car sound better but more importantly, run a bit more efficiently especially since its not stock.

Any questions about the Balt, all answered here:

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
RedSStreak is offline  
post #3 of 8 (permalink) Old 04-28-2011, 02:41 AM Thread Starter
Junior Member
 
Join Date: Apr 2011
Location: Jaffrey N.H
Posts: 17
Garage
i checked the piping and cleaned the MAF. i havent had a chance to drive it around yet to see if they come back on. ill take your advice about the o2 sensor and change it asap. the black smoke and running rich is normal cobalt things? and is there an easy way to get my wing off, or do i have to get a new trunk? thanks for the advice about the exhaust ill look into one.
Adamlovering is offline  
 
post #4 of 8 (permalink) Old 04-28-2011, 10:53 AM
Moderator
 
RedSStreak's Avatar
 
Join Date: Feb 2009
Posts: 1,087
Garage
My SS always has a crapload of carbon resin on the tip of the muffler just because they all run rich. If that doesn't solve your problem, then you may have to take it in to a shop that can diagnose the codes.

About the wing, that was not easy to take off at all. You have to start by removing the bolts on the inside of the trunk. Tape around the base of the spoiler with blue 3m masking tape so you dont scratch it upon removal. Get plastic wedges and use them to evenly remove the spoiler from the double sided glue. Once the spoiler is off, you can use goo gone or a rubber buffing wheel to remove and polish. Then you have to find body plugs or fabricate your own just like I did or you will have holes in the trunk.

Any questions about the Balt, all answered here:

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
RedSStreak is offline  
post #5 of 8 (permalink) Old 04-29-2011, 03:43 AM
Contributing User
 
Join Date: Aug 2008
Posts: 401
I too have similar idling problems. I have no upgrades or black smoke so I (and Chevy) do not why this problem is happening. As for the wing, I could always take that off your hands. :P
SupremeSlacker27 is offline  
post #6 of 8 (permalink) Old 04-29-2011, 09:55 AM
Moderator
 
RedSStreak's Avatar
 
Join Date: Feb 2009
Posts: 1,087
Garage
Whats up Slacker?!?

I told you that the wing could be yours a long time ago! All you have to do is give me $100 and pay for the shipping

Any questions about the Balt, all answered here:

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
RedSStreak is offline  
post #7 of 8 (permalink) Old 04-29-2011, 02:44 PM
Junior Member
 
Join Date: Apr 2011
Location: Central Indiana
Posts: 5
Check fuel pressure regulator if it has one and injector signal
PapaShrek is offline  
post #8 of 8 (permalink) Old 05-03-2011, 02:44 AM Thread Starter
Junior Member
 
Join Date: Apr 2011
Location: Jaffrey N.H
Posts: 17
Garage
she cobalt runs fine. altho the check engin light comes on and off alot. and its pulling a code for the maf. thanks for the tips on the wing, hopefully i can get it off. cuz that wing makes a big old blind spot. (BINLADEN IS DEAD, HELL YEAH)
Adamlovering is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Cobalt SS Forum : Chevrolet Cobalt SS Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome