New Cobalt SS owner - Chevy Cobalt SS Forum : Chevrolet Cobalt SS Forums
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 10-12-2019, 06:14 PM Thread Starter
Junior Member
 
Join Date: Oct 2019
Posts: 1
New Cobalt SS owner

I recently purchased a 2007 Cobalt SS. I have been working through some issues. New shocks/struts all the way around, new front wheel bearing, sway bar links, brakes and rotors. IT doesn’t like to idle. If it tries to idle around 850-900 rpm it will surge up to about 1400 rpm. It goes through this cycle of up and down about every second. I removed the factory exhaust system and replaced it with a ZZPerformance exhaust, 3” from the manifold to a 2.5” the rest of the way back. This helped the idle significantly. Now I am only experiencing the surge at idle 20-25% of the time. The inter cooler pump isn’t working (new pump on order). I have not been able to find any vacuum leaks anywhere. Other thoughts?
Joe012 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Cobalt SS Forum : Chevrolet Cobalt SS Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome