Chevy Cobalt SS Forum : Chevrolet Cobalt SS Forums - Reply to Topic
Thread: check engine light on HELP! Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Chevy Cobalt SS Forum : Chevrolet Cobalt SS Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
08-27-2007 05:19 PM
Show Off good looking out man!
08-27-2007 03:07 PM
zrated89 alright guys heres the deal i heard from the dealer and imagine that the converter was bad which i told them from day one. and you wanna know something else the converter is on national backorder hmm wonder why if you have a cat code get it check these things are known for leaky injectors and that my friend will fry your cat watch for symptoms.
08-26-2007 07:40 AM
Show Off yep yep!!!
08-24-2007 09:01 PM
zrated89 yeah like i said im a tech and i knew thats what it was im pulling like 18psi and it doesnt go anywhere but if i barely touch the gas it will so its def the cat i told them im bringing it on tommorrow and i want a rental dont call me till its fixed. i should have took my intake off everything else is gm but theyre pretty cool about that stuff anyway and an intake wont clog your cat but a leaky injector will
08-24-2007 05:14 PM
Show Off dont know about all that. it sounds fishy. sounds like a clogged cat to me that they should replace. catylist efficiancy meaning the cat isnt working right. i have heard from a few others that the cats like to clog op a bit more when doing some mods.
08-23-2007 07:06 PM
zrated89
check engine light on HELP!

allright guys heres the deal i have an 07 SS sc and my first mod was the gm performance exhaust. i put it on and almost imediately the engine light came on didnt notice a lack of power though. second mod K&N typhoon intake. felt like it ran good for the first day after i put it on. After that when i put the pedal to the floor the boost gage goes up past 15psi and starts to bog. i live in VA and went to richmond dragway. the best i could hit was a 15.9 sec qrtr ml. and stock it is 14.8 the last run it started bogging and the check engine light started flashing at me. So im a mechanic i figured to much air and exhaust not enough fuel right. today i had my stage two upgrade put on the car. Its slower than it was. the p0420 catalyist effecientcy below threshold bank 1 sensor 1. came on after i left the parking lot. but it will only come on at idle buts its weird because when i barely push the pedal it runs ok. when you put it to the floor now with stage two ill pull over 20 psi but the car isnt going anywhere. the dealer before i put the stage two on replaced the injectors and the o2 sensor that was supposed to be bad. they said it had a missfire code and i know these things are known to have leaky injectors. I came to the determination that 1 the dealer dont know shit, and 2 the leaky injector fried my cat. and it just seemed coincidental that it happened around the time i did my mods. im pissed i have the K&N cai, the gm performance exhaust and now my stage two and its bogging like hell. just curious if any of you guys had this problem with mods. or if the cats are known to go bad. i should be in the high 13's any of you guys with the same mods? what psi is it running at?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome