Cobalts SS banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
OK so I have a 06 cobalt ss lsj. I have recently started having a problem where the alternator is not charging the battery I have already put 2 different alternator on and changed the ecu. When I backprobed the connector on alternator it was putting out 4.3 volts with the car running. Any help is greatly appreciated I dont know what else to do thank you
 

·
Registered
Joined
·
8 Posts
As i can't find a wiring diagram for the car myself this may or may not help but I believe the charge wire out of the Alt goes to the top stud on the starter where it gets connected to the battery cable leading up to the post on the fuse box to join the main lead back to the trunk.
If the ~ 10agw wire is broken or suffered corrosion you may not be charging due to the lack of voltage sensing off the charge wire.

Have you done anything in the starter area lately?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
As i can't find a wiring diagram for the car myself this may or may not help but I believe the charge wire out of the Alt goes to the top stud on the starter where it gets connected to the battery cable leading up to the post on the fuse box to join the main lead back to the trunk.
If the ~ 10agw wire is broken or suffered corrosion you may not be charging due to the lack of voltage sensing off the charge wire.

Have you done anything in the starter area lately?

Yes I did change the starter about a month ago and I also had to change the crank sensor and take the starter out to do so
 
1 - 3 of 3 Posts
Top