Cobalts SS banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Ok so i installed a bomz intake that i got off ebay. i put it on, fired the car up, and it ran awesome and sounded sweet. the CEL didnt go off while driving about 15 miles to work but did when i took the car out for lunch. now im trippin.
what could be going on here?
everything looks correct in there so i'm at a loss for what the problem is. i've heard several things about this but just wanted to get a lil extra input from you guys.
thanks in advance!
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
ok, took her to autozone, got the code cleared. It was the "running rich" code p0172 i beleive. I don't think there is anything else i can do to fix that condition other than going back to stock intake.

If someone tells me something i can do to make that stop and still not void any warranties, i'd do it. Otherwise, im going back to stock and i'm done putting any mods on this car.
I HATE check engine lights. I don't drive cars with the CEL on. Bothers me. Plus the car runs like monkey piss with that intake on. stock was so much better
 

·
Registered
Joined
·
451 Posts
bombz isnt a good intake, they throw stuff together and dont test it, spend the extra money and get it from a copany thats been around, injen, aem, k&n... list goes on
 

·
Registered
Joined
·
414 Posts
It's the MAF placement. You can try unplugging your battery for about 15 minutes. When you reconnect it, the light will be off. Your computer needs to learn the new airflow coming in.

If that doesn't work, I'd recommend taking that filter that came with it, and doing the Airbox Mod. It may not look as cool, but you will still get the same effect (Sound, Performance)

Just my .02
 

·
Registered
Joined
·
46 Posts
The MAF answer is correct, the computer will learn to a point, but if the code keeps coming back you will need a tune to calibrate the MAF to the airflow of the intake, and by it running rich I suspect your new intake is not flowing that well or the MAF location is wrong. Almost everytime I have seen an intake related code it is lean. 2 cents.
 
1 - 7 of 7 Posts
Top