Cobalts SS banner

1 - 12 of 12 Posts

·
Registered
Joined
·
413 Posts
Discussion Starter #1
So this guy in town has a 97ish Camaro Z28 and he has some aftermarket stuff done like intake, exhaust, header, cam yadda yadda and I heard he ran a 15.5 and 14.6 in the quarter this past weekend....does that sound very right? For the mods that I know of and the car itself? I dunno the time sounds a bit high to me....wouldn't my car run mid 15s? :confused:
 

·
Registered
Joined
·
413 Posts
Discussion Starter #3
87camaroPA said:
Sounds about right.
Hmm a couple guys I know said that it should've maybe been lower 14s and maybe into the 13s
 

·
Registered
Joined
·
5,187 Posts
Well depends on how good of a driver he is, i know from mine it is really hard to get a good launch in the LT1 Camaro's they have such good low end trq. they will bust the tire's lose with no problem. And is he still getting used to the car or has he had it for a while?
 

·
Premium Member
Joined
·
8,648 Posts
97 "ISH" could be either the LT1 OR the LS1 now if it is DEFINITELY a 97 then it is an LT1. Startin in 98 they put in the LS1. Now that said, even though the LT1 makes less power than the LS1 if this guy has intake and a header back exhaust along WITH a cam: he should EASILY be runnin 13's. They ran low to mid 14's stock... where as the LS1 ran low to mid 13's stock (with a few freaks breakin 12's)
 

·
Site Moderator
Joined
·
3,724 Posts
CoBIZZLE said:
97 "ISH" could be either the LT1 OR the LS1 now if it is DEFINITELY a 97 then it is an LT1. Startin in 98 they put in the LS1. Now that said, even though the LT1 makes less power than the LS1 if this guy has intake and a header back exhaust along WITH a cam: he should EASILY be runnin 13's. They ran low to mid 14's stock... where as the LS1 ran low to mid 13's stock (with a few freaks breakin 12's)
Yea, but if it's still the stock motor, you gotta remember that thing's 10 years old. It doesn't have the same pull as it did when it was new. He might be running 13's, but they'd be mid-13's at best. Just a thought...
 

·
Registered
Joined
·
1,170 Posts
I don't know about that 13's. What is the elevation for this threads starter? I'm at 4700' and my friend with a 98 camaro ls1 is running 14.4 at the best.
 

·
Registered
Joined
·
132 Posts
Bone stock my 95 Z28 ran 14.1 @ 97mph on a 2.1 60ft. That was with 74K on the clock and late June weather. That was an Automatic 3:23 car with T-Tops, Bose 5 speaker and every other available option.

The 96+ got dual cats and were rated higher because of the better flowing exhaust.

FWIW with a cam (CC306) and headers (BBK Shorty) I was will into the 12s without traction and trapping 115ish in the 1/4. With just boltons my auto went from trapping 97mph to 103mph and that was without headers.

Elevation does come into play as mentioned above...where are you? whats the DA?
 

·
Registered
Joined
·
413 Posts
Discussion Starter #11
Well I know its before 98 because of the headlights, and the elevation is 1949ft above sea level, and I'm pretty sure he's used to the car by now because I think he got it brand new back then.
 

·
Registered
Joined
·
132 Posts
Hmm.. he should be probably in the mid 14s at that elevation... of course just like every other car some were weak sauce and some rocked.

On CZ28.com a few stock LT1 cars ran 13.3 ~ 13.6 in the 1/4 untouched others ran 15s.
 
1 - 12 of 12 Posts
Top