Cobalts SS banner

1 - 20 of 21 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
So recently my ABS light came on. I said hummm, might just be some error it'll go away. Well drove it for a bit, turned the car off, and it sounded like something kept running under the hood. Turns out the little ABS module/pump or whatever it was wasn't shutting off with the car. I tryed pulling out the fuse and that shut it off. Then I just put it back in and brought it to the dealer. Anyone else had this problem, I've had no SS for the last 3 days...but they've been closed and I should be getting it today, will post what they say
 

·
Registered
Joined
·
309 Posts
Could be some terminal that is bent. I had a CEL light come on and it was because a terminal for the intercooler pump was bent keeping it on all the time (very annoying as it is loud). I know its not the same problem but it's sort of related and just thought I'd throw it in there.
 

·
Registered
Joined
·
41 Posts
I haven't had that problem yet but then again the mechanic has spent more time with my car than I have. May I'll be lucky enough to have to have that fixed also.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
Found out it was some brake sensor that was jammed? Now i gotta wait 2-3 days for it, im hoping for 2 days, so then I could say It took a week instead of 8 days to get my car back lol
 

·
Registered
Joined
·
695 Posts
damn talk about brakes.. my e brake light randomly comes on when i am driving.. and its hestitating to start again like i have been saying
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
The 12th and still no Cobalt, makes it about 10 days, I don't think I'm ever going back to this dealer to get it serviced ever again...all they had to do was replace an ABS sensor, no way in hell that takes 10+ days..
 

·
Registered
Joined
·
15 Posts
so far i have had the ebrake light come on while driving, abs light on 2 times and now i have the padlock light come on while driving and today it prevented me from starting the car. i am a tech for BMW and i dont feel like having someone look at my car when there hasnt been enough cobalts in the shop yet to figure out whats going on but it is preventing me from relying on my car so i might have to suck it up and bring it in. god i hate someone working on my car. also does anyone else have a slight delay when pressing the accelator pedal to the engine rpms going up? if i hit the pedal isnt an instant response. this cars are throttle by wire so there shouldnt be any delays. the tech is going to love my car haha
 

·
Registered
Joined
·
3,049 Posts
My ABS light just came on last night and I heard a sound under the hood just like you. I called my dealer today and it will get looked at Monday. Also this morning the brake light is now on. I do put on my e-brake whenever I park it just out of habit since I've had manaul tranny's in the past pop out on me while parked and then my car rolls down the street. :)

I also notice that my steering feels a little slow at low speeds but is find at hard corners. Is this just the nature of the car or do I need to have that looked at too?


I'm starting to get frustrated with my car, I only have 1K Miles on it. Never in the past has a car given me so much trouble before at least 50K miles. :mad: I do see how other folks have it much worse....I just don't know how GM can have a car pass QA with all the problems that are out there. If it continues I might bite the bullet in a year or two and trade out of it. I hope I don't have to do that since I love my car but I need it to be reliable stress free. Life has enough of it's own curves on it's own.
 

·
Registered
Joined
·
3,049 Posts
That is my experience with it. And it feels like a number or 'dead' spot on-center when cruising. I even notice it is a little 'loose' unless I'm pushing through a tight turn. No complains on the turns just curious about cruising speeds. Especially since I am seeing issues with the Rack and Pinion steering components on various threads. Also with having the ABS and brake light issue on my car I am a little worries. I've never had trouble with a GM vehicle before. I've had GM's as old as 1989 and no issues other than usual maintenance. So I am gunshy, also is it me or are a lot of folks having multiple problems with the Cobalt SS/SC and regular Cobalts?

I had an '03 Cavalier LS Sport Coupe that never had an issue, and a 1998 Z-24 Cavalier that went 140K before anything went bad.
 

·
Registered
Joined
·
3,049 Posts
I took my SS/SC in this past Monday Oct. 17th to the dealer. It needed a chip in the door from the Dealer lot repaired and the ABS/Brake light looked at.

The body damaged was fixed by Tuesday Morning but the ABS/brake is still an issue. The dealer received the new abs module yesterday afternoon and as of this afternoon 'they are still working out some trouble-codes' according to the service manager.

If anyone has the ABS light issue and hears something sounding like a small device or fan still running from the drivers side area of the hood chances are your ABS module is dead. Be prepared for at least a few days of downtime as most dealers will not have the part in-stock.

I'll let you all know how this turns out and what if anything is to the 'remaining trouble-codes' that my car is still throwing.
 

·
Registered
Joined
·
3,049 Posts
(SS) with a SS said:
My parking brake light has now started to come on while driving. Looks like it is another trip to the shop.

Does it stay on all the time? Do your brake lights still come on?

Reason why I ask is that my car had the ABS light come on, then the brake light came on the next day. My dealer replaced the ABS module and then found out that the ABS module shorted out the Body Control Module as well. The Body Control Module is on National back-order. I have been waiting a week(My car has just been sitting in the dealer service lot), but told me that the part will be in tomorrow or the next day.

Just a heads up if it is the BCM, it may take a while.
 

·
Registered
Joined
·
3,049 Posts
Dealer called me yesterday to say that they found my BCM (Body Control Module) and it will be over-night shipped to the dealership. Today still no part but they expect it tomorrow. Keep in mind that dealers are having a really hard time getting parts for the Cobalt and the Colorado. They don't like it, I don't like it....hopefully GM can get a handle on things that are coming from business partners.....my cobalt has been down for 10 days now and counting. I'll keep you all posted.
 

·
Registered
Joined
·
3,049 Posts
CobaltSSilver said:
Dealer called me yesterday to say that they found my BCM (Body Control Module) and it will be over-night shipped to the dealership. Today still no part but they expect it tomorrow. Keep in mind that dealers are having a really hard time getting parts for the Cobalt and the Colorado. They don't like it, I don't like it....hopefully GM can get a handle on things that are coming from business partners.....my cobalt has been down for 10 days now and counting. I'll keep you all posted.

They replaced the BCM and the seatbelt light came on...a totally new issue with my car. Also I found some damage to the interior along with grease stains on the front bucket seats. They had also scraped up the passenger side rocker panel/side skirt and took it off to repair it. All they did is paint over the damage and it looks like ass. Needless to say I am unhappy with the dealership and now I wonder if I have a lemon as they ordered another BCM module and it will be in Friday November 4th. My car has been in the shop since October 17th. :mad:

I'll send another update as the world turns ;)
 

·
Registered
Joined
·
3,049 Posts
CobaltSSilver said:
They replaced the BCM and the seatbelt light came on...a totally new issue with my car. Also I found some damage to the interior along with grease stains on the front bucket seats. They had also scraped up the passenger side rocker panel/side skirt and took it off to repair it. All they did is paint over the damage and it looks like ass. Needless to say I am unhappy with the dealership and now I wonder if I have a lemon as they ordered another BCM module and it will be in Friday November 4th. My car has been in the shop since October 17th. :mad:

I'll send another update as the world turns ;)

Well the horror story takes a slight break from trying to scare the piss out of me. My cobalt EBCM for now is working. I am told another tech programmed it and all is well. The damage caused by the dealership is all fixed save for three things. Dash top needs to be replaced (Part on order) Driver-side step moulding (Yet another part on back-order) and I still have one grease stain on the front passenger bucket seat. I give them an improved rating for effort. They replaced the rocker panel off of another cobalt and repainted the step in area on the driver's side that they scratched up. Hopefully this thing will hold up and the dealer will come through with the other two parts and cleaning of my seat or replacement of the seat insert.

I did read this week that the Cobalt in 2005 models had the worst reliability rating per Consumer Reports so it's not just a bunch of folks here whining for nothing shit is definately wrong with the car. Hopefully no one else has to go through what I have gone through. The car when running is a great running little car, very comfortable and looks super HOT! But I will not live with a lemon no matter what GM or the dealer wants.
 

·
Registered
Joined
·
3,049 Posts
CoBIZZLE said:
Wow! Sorry bout ya luck man! Hope it changes for the better!

Yeah me too. It was bad enough I had a bad EBCM in the first 1000 miles, along with damage to the car on the dealer lot before I took deliver but to make matters worse the dealer added to my pain with the additional damage to the vehicle. Worst car buying experience I've ever had!
 
1 - 20 of 21 Posts
Top