Cobalts SS banner

1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
ok, ive been having this problem for a while now. I bought my 2006 Cobalt SS/SC in may with 18k on it. When the car is sitting still and you lightly tap the gas to rev it blows out black smoke from the exhaust pipe for a sec (im not talking about anything anywhere near redline either). I have been told from people following me that it puts out black smoke while i drive under normal driving too.

I had this checked at my local dealership and they told me that its normal for these motors when you get near redline to expell some black smoke, but i dont have to be near redline at all (I tried to explain). They said they had an updated reflash for my car that might help, so they did it but I dont think it helped any. So what do you think is wrong and what should I do?

Also my car has a Borla Cat-Back exhaust and a K&N drop-in filter if that matters

Thanks for the help
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
thanks for the input, i will have to get that checked out. I am still open to any other ideas anyone has, i want this fixed so i can get the stage 2 kit without being worried that something big is wrong with it.

I also forgot to mention that my car has about 23k on it now, and the exhaust has been on for about 3k and the K&N filter has been on for about 1k. The smoking has been happenning for quite some time now, though (not exactly sure when though).

Again, thanks for the help
Chris
 

·
Registered
Joined
·
2 Posts
well buddy I dont know what to tell you on the black smoke but I own a 2006 Cobalt ss/sc with a stage 2 kit,GMPP Exhaust,Honed manifold, and injen cold air intake! My car smokes just like you are talking about! Since day one may I add! and to add to this my buddy just bought a 2007 cobaltss/sc that is completly stock and does the same thing!
 

·
Registered
Joined
·
5 Posts
Dude, i got an 07 sc and it does the same, only have 7500km on it, and my friends have been telling about it for a while. i made an app. at the dealer, my friend thinks it may be a piston ring and its burning oil, and yes, it is low on oil, about 0.7L in 2500 km. im pretty worried about it, i have injen CAI and a high flow muffler. im waiting until it gets fixed to get stage 2.
have you guys heard any more on this problem?
 

·
Registered
Joined
·
5 Posts
could it be something with the injectors? something must not be burning right, maybe a bit of oil blow by. when i get to operating temp. (around 80c) then it seems okay.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #9
Mine is still smoking even after the updated version reflash. Also i was following the girl that lives a block away from me home the other day who also has a supercharged cobalt, I seen that hers was smoking black smoke too. So i wonder if this is really a problem or is it just they way GM built these cars. Its kinda stupid if its normal cause when someone sees a nice car like a SS/SC cobalt they arent expecting to see it smoking.
 
1 - 10 of 10 Posts
Top