Cobalts SS banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hey guys my brother recently bought a 2006 SS cobalt. And I have no idea whats under this hood so far to me it looks like it just has a full exhaust on it with a stock supercharger. I have no idea if this is normal or not but his car pushes about 12 lbs. at full throttle. Recently, however, it only opens up to about 5 lbs. I know that this is not normal for this to be happening but if anybody to give me info. or advice about this situation it would be much appreciated. Thanks guys.
 

·
Registered
Joined
·
190 Posts
if ur not going into it full the car isnt gonna boost 12 psi which is stock psi boost BUT if u are going all into it and it lags i do believe u have a problem because only turbos have lag even tho the stock ko4 turbos on our cars are twin scroll and barley have any lag but urs is a supercharger so it should be direct power with no lag once so ever
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
and thats why im confused i even drove his car and i pushed it as hard as i could in every gear and it wouldnt go passed 5psi when it used to go up to factory boost. im a big turbo guy myself and i honestly know nothing about superchargers hence why im on here lol
 

·
Registered
Joined
·
190 Posts
well heres somthing to think about when i tuned my car and had stock map sensors my car wouldnt booost past 7 like even all into it so i got new ones and tuned it for them and it boost 27psi now sooo that might be a problem i honestly dont know
 

·
Moderator
Joined
·
1,087 Posts
Ouch, it sounds like your SC is on its period because it doesn't want to operate at normal levels lol. No really, it may be the belt, tensioner or pulley that is causing the low boost. OR, if you have a CEL on, then first find out what that is and it may be the purge valve. I had a boost problem, not like yours though, until I cleared the purge valve code on my Balt too.
 
1 - 6 of 6 Posts
Top