Cobalts SS banner

1 - 19 of 19 Posts

·
Registered
Joined
·
283 Posts
Discussion Starter #1
I just picked up my Cobalt and the check-engine light came on with only 43 miles on fning car!!. I brought it up to a dealership right away they are taking a look at it right now I will keep you posted on it. Also did anyone else have the same problem with that too???
 

·
Registered
Joined
·
234 Posts
BizoCG said:
I just picked up my Cobalt and the check-engine light came on with only 43 miles on fning car!!. I brought it up to a dealership right away they are taking a look at it right now I will keep you posted on it. Also did anyone else have the same problem with that too???

I wouldn't sweat it :) it could be something like they didn't tighten the gas cap when they filled you up!
 

·
Premium Member
Joined
·
8,648 Posts
Yeah man, its already happened, I cant remember exactly what it was, I think it was Ronnie Pendergrass's car that did it?!?! Whoever it was they said it was a wire that had been rubbin up against the blower I think and the insulation had melted away teh wire probably grounded out causin the light.

I'll do a search real quick and see if I can find the thread... one sec...
 

·
Registered
Joined
·
156 Posts
it was my light that came on for the wire up against the blower, and the battery cable was loose and it was loosing "keep alive memory" all fixed and no more problems.
 

·
Registered
Joined
·
283 Posts
Discussion Starter #8
it was my light that came on for the wire up against the blower, and the battery cable was loose and it was loosing "keep alive memory" all fixed and no more problems.

That is the same thing that happened to mine!!! lol lol That's F$#^ed up!!
 

·
Registered
Joined
·
5,187 Posts
BizoCG said:
it was my light that came on for the wire up against the blower, and the battery cable was loose and it was loosing "keep alive memory" all fixed and no more problems.

That is the same thing that happened to mine!!! lol lol That's F$#^ed up!!
Really is that what they said was worng i think GM needs to fix that problem and they need to grind that boolt down that is right next to the intake off a bit that is two problems so far but only the one will do alot of damage. In a way it is good that is only that so far. It could be far worse.
 

·
Registered
Joined
·
434 Posts
How much milage have you guys put on the car before this CEL came on? I'm almost at 2000 and everything fine so far
 

·
Registered
Joined
·
434 Posts
I was wondering if anyone when your check engine light comes on if anyone has used onstar and had them run a test?
 

·
Registered
Joined
·
90 Posts
ok, the damn light came back, which wire on the blower is everyone talking about?
 

·
Premium Member
Joined
·
8,648 Posts
I actually think it is just a wire that is supposed to rub up against the blower or somethin, could probably be fixed w/ a zip tie. Also check your battery terminal, just posted this on the other thread, just tryin to make sure ya see it, good luck!
 

·
Registered
Joined
·
26 Posts
Was Light Flashing or solid.

On that vehicle it usines a bused electrical center so it is emmision related if it is constant and powertrain if flashing. One mis-fire will make it flash and a decent dealer will figure it out quickly. There are very few moving parts so it will be a program fix. If it is solid %90 of the time you did not cut the vehicle off when you filled up. The tech will right down OE (hee hee) {operator error} :eek:
 

·
Registered
Joined
·
434 Posts
I got a digital camera yesterday and I'm now able to take higher quality photos and I captured one of the alleged wire thats causing the CEL's....
 

Attachments

1 - 19 of 19 Posts
Top