Cobalts SS banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Anybody out there get a knocking noise when they start their car.It seems to happen more often on cold days.It only lasts a few seconds then disappears.
I brought it into the dealer and of course they could not hear anything when they started the car.I drive a 2006 cobalt ss sedan.
 

·
Registered
Joined
·
9 Posts
i drive a coupe 2.4 and no knocking noise when starting in the cold and it's cold here.
 

·
Registered
Joined
·
15 Posts
Anybody out there get a knocking noise when they start their car.It seems to happen more often on cold days.It only lasts a few seconds then disappears.
I brought it into the dealer and of course they could not hear anything when they started the car.I drive a 2006 cobalt ss sedan.

From what your discribing it sounds like piston slap !! Just a thought ! Does it go away as the cars engine warms up ?
 

·
Registered
Joined
·
202 Posts
Ticking

i posted somethig like this b4 my 2.4 has a little ticking noise at first start up i think its injectors not sure. but its quiter when warm. ill have the dealer check it out and do some other things like fix my blown speaker.

ryan.
 

·
Registered
Joined
·
15 Posts
i posted somethig like this b4 my 2.4 has a little ticking noise at first start up i think its injectors not sure. but its quiter when warm. ill have the dealer check it out and do some other things like fix my blown speaker.

ryan.

It could be injectors ? But the old 2.2L where famous for a small amount of piston slap !
 

·
Registered
Joined
·
147 Posts
i have this problem with my 98 malibu 3.1L. i brought it to the dealer and they gave me a printout saying that it was normal for the engine and wouldn't affect the life of the engine. they even extended the warranty on the engine. that was at 70,000 miles i'm now at 89,000 and it doesn't seem to be getting worse. if it only lasts for a few seconds i wouldn't worry about it unless it starts getting worse. you said you brought it to the dealer and they didn't here nothing, did you tell them to start it when the engine is cold?
 

·
Registered
Joined
·
21 Posts
kind of an offtopic vehicle, but my mom has a 2000 Regal 3800, and it ticks for a second or 2 on startup, again GM says its normal. Its done it since day 1 and now has 60,000 miles and its no worse than it was to start
 
1 - 8 of 8 Posts
Top