Cobalts SS banner

1 - 8 of 8 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter #1
Hey everybody so i have injen cai on my ss/sc and after i put the stage 3 kit on it, it idles funny and takes like 30 seconds to get set and it does the same thing after coming to a stop, any idea on how to fix that. thanks
 

·
Banned
Joined
·
59 Posts
well you need to add some more info bud is your stage 3 a gm stage or is it a **** zzp or intense stage because if its any of the 3 non gm brands chances are it can be a few things

air fuel
maf
case relearn
poor fuel lines
or its just really cold out

when i do a cold start your car should idel ruff for about 20-30 seconds and once u hit engine temp of 160-180 it should idel really good if its bad at those engine temps check the other things

and then ill hit you up to see whats happenin
 

·
Registered
Joined
·
29 Posts
Discussion Starter #3
well it from zzp, and its like 35 degrees out, zzp said something about the cai being the problem, and i check to see if there was any holes in cai there was none, so im lost
 

·
Banned
Joined
·
59 Posts
ok now i help you did it run good without the cai? if it did then it is just because your getting the more air intake and are not tuned for it. and that can be whats throwing off your cars rmp


however you might want to take the breather off your intake and put a cone filter on the breather of your engine but only do this after you get some spray and clean out your maf on your intake and see if oil is not spraying your maf causing it to not read right.

also put some injector cleaner in it to see if fuel is not the problem



did you send your pcm into them or did you get one from them and had to ship yours back because if thats the case then you might need to do a crank case relearn
 

·
Banned
Joined
·
59 Posts
o holy cow its normal for that in 35 degree weather cause your car eats more fuel in the winter do those things just to be safe its about 12 bucks and its good to have around anyway
 

·
Moderator
Joined
·
1,087 Posts
You should check to see if there are any holes or if there are no leaks at all after the Mass Air Flow sensor (ie. loose clamp). That would be why the car would be Idling funny.

Or my other question is: do you have the AC on when this happens because that is a very common problem that plagues the Cobalt. If you have the AC on, it will cause the car to idle really rough. And atop of that, you are in cold weather so starting it in the morning is really frustrating with a cold seat. :D
 

·
Registered
Joined
·
29 Posts
Discussion Starter #8
well it ran fine with out the cai and also the pcm was tuned for it, i just cleaned the thr***le body and it help but its not as bad now,
 
1 - 8 of 8 Posts
Top