Cobalts SS banner

1 - 5 of 5 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
so i just picked up my 06 SS/SC today, and drove it around for a while. and when i turned it off and came back to start it i pushed the clutch down and nuthin just the engine light, i tried turning the key again nuthin. so i let my foot off the clutch and turned the key again and it started, but it sounded like it had trouble turning over, but i dunno if its supposed to be like that cuz im used to my old lancer the once i turned the key engine turned right away. but i dunno, has anyone had this problem or know what causes this problem? if anyone could help that would be awesome, i am also calling the dealership tomorrow to see if they can look at since i havent even had it for 12 hours yet. anyway thanks alot
 

·
Registered
Joined
·
2,444 Posts
CalgarySS said:
so i just picked up my 06 SS/SC today, and drove it around for a while. and when i turned it off and came back to start it i pushed the clutch down and nuthin just the engine light, i tried turning the key again nuthin. so i let my foot off the clutch and turned the key again and it started, but it sounded like it had trouble turning over, but i dunno if its supposed to be like that cuz im used to my old lancer the once i turned the key engine turned right away. but i dunno, has anyone had this problem or know what causes this problem? if anyone could help that would be awesome, i am also calling the dealership tomorrow to see if they can look at since i havent even had it for 12 hours yet. anyway thanks alot
Search is your friend...(always wanted to say that :D :p ). http://www.cobaltss.com/forums/showthread.php?t=1575 I am guessing its that wire problem or the battery problem.
 

·
Registered
Joined
·
45 Posts
I had the same problem got it towed to the dealer and they checked the battery it was good the said it was the clutch safety switch since it wouldnt push start or nothin. Just got it back 2day seems to start fine... so far
 
1 - 5 of 5 Posts
Top