Cobalts SS banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I test drove an Cobalt SS today and I thought the car would have more pull than it have. I am not sure if the car was running correctly though. I couldnt really hear the super charger kick in ever.

Also when I was test driving the car the boost gage was not working correctly. I thought the gage wasnt working at all, but when I hit 6000 rpm or so it would shoot to 20psi on the vacume side. All the other time it would sitting right on -10psi. Was there just a problem with the gage or was the super charger not working correctly. I told the dealer that the gage wasnt working correctly and he said it hasnt gone through there shop yet. He was going to send it through the shop. Could it have been that the super charger wasnt working correctly or was it most likely the gage is not working correctly.
Does any one have any ideas.
 

·
Registered
Joined
·
18 Posts
the supercharger is engaged at all times. Maybe there is something wrong with the gauge. As far as the sound, in stock for u might not hear much. Put a smaller pulley and you will hear it all day long:)
 

·
Premium Member
Joined
·
8,648 Posts
Yeah sounds like it has issues!! At first I thought it may have been one of the fake SS's. Dealers have been puttin body kits on regular coupes and callin em SS-R's or somethin like that, from what I hear. But that wouldnt explain it havin a boost gauge?!?!
 

·
Registered
Joined
·
80 Posts
Like all production cars, there are problems that occur. Don't think that every SRT/EVO/STi/Cobra came off the line without a vacuum leak.
 
1 - 5 of 5 Posts
Top