Cobalts SS banner

1 - 20 of 22 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter #1
Besides the charge air pipe that pops loose and the paint that rubs off on the bottom of the doors, what other common problems should I look for before buying a new 09 SS/TC?
 

·
Registered
Joined
·
147 Posts
rear brakes dragging and putting a groove in the rotors. hasn't happened to me yet but it has to a couple of people on another site.
 

·
Registered
Joined
·
147 Posts
intake camshaft sensor leaks oil. no fix yet but gm is aware of it. the dealership just replaces it with another that will leak again eventually.
 

·
Registered
Joined
·
53 Posts
Discussion Starter #4
The rear brake issue sounds like the emergency brake is binding. It's common on 05-up Mustangs as well and usually it is because the e-brake line is rusted/frozen.
 

·
Registered
Joined
·
147 Posts
its not in the e-brake housing its on the rotor. these are 4 wheel disc brakes. the emergency brake is a drum set up inside of the rotor.
 

·
Registered
Joined
·
53 Posts
Discussion Starter #6
Ok - I wasn't sure about that, the S197 Mustang e-brake is the service brake (rear pistons are screw-in), my Crown Vic has the drum set-up for the e-brake (service brakes are all discs).

Are the rear SS brake calipers on sliders? Is it a lubrication issue? Or perhaps it is a friction material problem? My stock factory Crown vic pads chewed the sh*t out of my stock factory rotors.
 

·
Registered
Joined
·
147 Posts
its not a lube issue i don't think. all the cars having the problem are 10,000 miles and under. i only have 4,000 and i here the rubbing but i don't have a groove yet. there is a tsb for the noise but not for the groove.
 

·
Registered
Joined
·
147 Posts
yah i herd that too but it hasn't happened to me
 

·
Registered
Joined
·
414 Posts
yes it does. Already in the dealer twice for that crap^^^
 

·
Registered
Joined
·
414 Posts
I'll be honest, i shift it pretty hard and really fast. But its a complete shift, no grinding or anything. The clutch HAS slipped a few times though
 

·
Registered
Joined
·
127 Posts
Also you might wanna check the CD player, i have an 08 and i had issues with mine recently and took it in and got a new one but i guess if you are planning on taking out the stock player than you have no worries... Just thought i would let ya know :) Happy hunting
 

·
Registered
Joined
·
53 Posts
Discussion Starter #15
I am going to keep the stock audio unit. They all come with the USB port, apparently it was a change for 2009.5 SS/TC's.
 

·
Registered
Joined
·
127 Posts
Well i have an 08 and the CD player messed up on it but they will replace it under warranty if it does, anyways, good luck
 

·
Registered
Joined
·
8 Posts
'09 tc

Was pulling out of the car wash today and the display goes crazy. "service esc" I have had it for less than 2 months and its already going to the service department!
 

·
Registered
Joined
·
8 Posts
Yeah, esc shut down, light came on, ding ding. Had a loud shut down noise to it. Thought i blew a tire. Oh well its going in for service tomorrow. I'll find out then.
 

·
Registered
Joined
·
127 Posts
Oh when i first got my car, i went to go and wash it and the next thing i knew the engine light came on and then i drove it to the gas station and it died there. It started again but i took it in and they had to get me a new ecu...
 
1 - 20 of 22 Posts
Top